19
xzvf
70d

Naming things is hard.
This is what I just wrote.
I was about to write the corresponding function with the prefix "calculate" and then this name.
Only then I realised how bad it was.

Comments
  • 7
    My brain skipped all the text and most of the image, immediately spotting the "FixedUpdate" phrase - then proceeded to chant "Unity" in a ding-dong-ish kinda way :D
  • 3
    @NickyBones same here.
    also, a 2d physics game
  • 2
    how about
    totalForcePerFixedUpdate?
    a bit shorter, and semantically almost the same
  • 2
    This is usually a sign that you need to refactor

    Or re think your class design and how the objects communicate with each other

    Is their a higher level of logic you can apply somehow somewhere so that by the time you get here you need less words because it's already within a context that speaks for most of the words you want to put in there?
  • 1
    @rant1ng The naming was redundant.

    I replaced with "totalForce" because the rest was clear from context. Also, it might be completely removed shortly.
  • 1
    Holy frigg
Your Job Suck?
Get a Better Job
Add Comment