4
CptFox
5y

Please help, I can't figure out good names for my API :(
AsyncReadWriter and AsyncWriter are really close tokio's AsyncRead and AsyncWrite traits, it's confusing, and also you're not supposed to instantiate AsyncWriter yourself.

https://crates.io/crates/...

It's also kind of a shameful plug for my tiny lib, it's my first open source one, hopefully first of many

Comments
  • 0
    DoWhenever —> AsyncReadWrite
    PushWhenever —> AsyncWrite
  • 1
    @bkwilliams I think IoManager and IoWriter would be somewhat more appropriate, but you know what, I'll add a namespace "silly_tokio" for type aliases with these names, because they are fun :D

    Also I'll alias Streams to "ValuesHappen" and Futures to "Promise" (take that JS :p )
Add Comment