5
lunorian
281d

And now PGP/GPG is vulnerable.. fml 🤬

Comments
Your Job Suck?
Get a Better Job
Add Comment