Do all the things like ++ or -- rants, post your own rants, comment on others' rants and build your customized dev avatarSign Up
For one being async and the other is not?
@MrCSharp while I understand that from a practical level, this kind of thing reminds me of why people shit on PHP. Inconsistency is maddening. Either of these could have been named differently in order to clearly depict how they behave. Now every time I want to use one I'll have to look up which one does what.
@CodeMonkeyG Yes, I agree with you. This kind of inconsistency is annoying. In .Net, MS naming convention for methods says that methods which execute asynchronously should have 'Async' as a suffix. This makes it easier to know how to deal with some methods.
Web Front End languages lack massively in consistency.
.net method naming... I cant put a finger on anything that is named annoyingly.
Maybe the unsure parts where it is either .Length, .Count, .Length<>() or the like. VS always fixes it to the correct method so, I don't mind
@jespersh i think of it like: .Length for arrays, and .Count for lists. Of course we have the IEnumerable objects which you have to use the .Count() method and it makes sense because it will actually go through the items to count them. So a tip for linq, don't do a .count() on ienumerable then enumerate it with foreach because then you'll evaluate it twice 😁
Your Job Suck?
Take a quick quiz from Triplebyte to skip the job search hassles and jump to final interviews at hot tech firms
Get a Better Job