8
lxmcf
22d

Give me strength people, I may have to have an install of stock ubuntu just to use unity because the UI is unusable on Elementary OS...

I feel dirty..

Comments
Add Comment