10

Aaaand this made me cringe.
When you are being a good slave and filling in one of those in chrome official stable release on ubuntu GNOME...
It's saying I either need chrome, firefox or internet explorer...

Comments
Add Comment