I spent $2500 on a paperweight.
AMD Threadripper 1950x
ASRock X399 Fatal1ty Professional Gaming Motherboard
Corsair 32GB DDR4 2666 MhZ RAM

Can't even power up beyond chassis lights
Beyond frustrated, exhausted

  • 5
    So...the PSU is underpowered ?
  • 6
    what @avitron said, Its most likely that you AyyMD PC lacks a good PSU, is it rated 80plus?
  • 2
    conect the most basic stuff that you absolutely need and check if it boots, if not there could be that there is a short circuit somewhere or iunno, there are alot of factors to take into account
  • 2
    Check if the RAM is compatible w/ the Motherboard and CPU. There are some issues related to this.
  • 2
    that sounds like a desktop pc, I'd never use it to weigh down my papers.

    > "hey do you have a paperweight?"

    > "no but my big and expensive ass desktop is right over there"
  • 3
    Don't give up. I built a lot of systems so far and it never worked flawlessly on the first try. Does the mobo show any error codes/beeps or does it turn off emediately after turning on?
  • 2
    Did the tr4 socket close easely?
    If not, you probably have a problem with your socket.

    Rumors say that the screws holding it in place might be "louss" / need to tightened.

    Rumors also say that it's a foxcon problem, but foxcon makes good stuff, I rather think QC problem in the factory where they build the boards.

    RMA should be very simple in this case.

    Good luck und success
  • 1
    And what are the last numbers on the small 8 segment displays?
    Aka Post Code Display?

    That will tell you are in the Post Process.

    If no numbers appear at all, you have some major problem.

    But before i start throwing everything at you. How is it going? Postcode pls?
  • 3
    @RageBone yea the foxcon sockets are shit you need a lotus socket to make sure it closes ok
  • 0
    Looks.like you have a foxcon socket check all the screws again and if needed use your body weight to push down on the screws
  • 2
    @inpothet sorry but don't, at all.

    You will probably damage the socket and or CPU substrate.

    You should check the surrounding socket screws, maybe untighten then, wigel for better seating, and tighten them again .

    I actually haven't heard of a solution for that, this is just an assumption worth trying, before RMA ing that board
  • 2
    @inpothet @ILMostro
    Everything I have read so far points to a slightly miss aligned socket.
    The CPU will not sit flush in the socket and the screws can't catch because of that.

    Pushing down, can make it work, but I'm sure that you will rather damage the socket and the CPU substrate.

    Tldr: don't push down.

    Change the alignment.

    And sorry for the down-vote, but I had to : (

    And I believe this be a problem in the manufacturing of the boards and not the foxcon socket.
  • 2
    @legionfrontier It's all part of AMD's own Recommended hardware list. 750W EVGA 80 plus gold rated. There's barely any peripherals, just a single Radeon 550 GPU. I tested it using wire between Ground and Poweron pin, works fine.
  • 1
    @jobylie Thanks for the encouragement. I've built plenty of servers working in a Datacenter before. Seeing a lot of people having issues with Threadripper builds is discouraging, even though I desperately want to get it built and use it.

    The Motherboard comes with a gimmick called "Dr. Debug", which is a 2-digit display counter intended to show POST error codes. However, I never get past the blinking lights on the Board. I can't find any useful info on how to interpret the sequence of those lights, in case they're used to show Errors. No discernable noise, no beeping, no spinning fans. Even the PSU fan doesn't spin when plugged into MoBo.
    I've tried reseating the CPU, cooler, moving RAM across various DIMM slots, using a single RAM module, no dice. Contacted ASRock, awaiting response.
  • 3
    @ILMostro No numbers on the DR.Debug aka PostCode display, means that the board isn't even powering on properly.

    How does the board behave without a CPU installed, when you try turning it on?
  • 1
    @RageBone Yes, I've seen that as well. It suck out to me because of the noticeable difficulty I've had with the CPU cover. Indeed, it seems to be the Foxconn board, while the Lotus board is unaffected. Like I said, tried reseating CPU, both times the cover was closed as intended; completely screwed down while not over-tightening. So that can't be it
  • 1
    @RageBone That was going to be my next move tomorrow: taking board out of chassis and without CPU and/or RAM. Too exhausted today 😁
  • 3
    @ILMostro I found an article that matches your issue, the mobo is x399, but a different variant. Check it out, hope it helps


    Edit: Whoops, ignore it. It's Asus, I got confused with ASRock 😅
  • 2
    @avitron That sounds EXACTLY like my problem. However, the thread shows no solution 😂 And yeah, btw, even though it's a different Brand, ASUS vs. ASROCK, the problem sounds to be the same for some reason.
    I might try exchanging Motherboard and CPU at local store, Microcenter
  • 3
    @ILMostro Haha yeah. Seems like exchange is a better option for now, just to be safe.
  • 2
    @RageBone check jayz2cents vids he a vid about this
  • 3
    @inpothet i don't know which you mean, and I can't remember that he gave a solution.
  • 1
    @RageBone he didn't but he reported that it wasn't the board but the socket, multiple report on the internet actually report that the foxcon sockets are shit
  • 2
  • 3
    @inpothet yes, thanks.
    But sadly still no real clue on why that is the case. And sadly no hint on what's up with OPs board.
  • 2
    It's gotta be the board. Same thing without anything plugged in. Unless it's the socket on the board and/or CPU.
  • 2
    @ILMostro first of all: why is there still the warning sticker on your cpu? Secondly, which even disturbs me more: the 24 MoBo Pin isn't connected properly. Why do you gotta make me suffer? :/
  • 2
    @niederschlag That was just the last effort before returning after I took out everything. Simple test to see Motherboard power on only.

    Returned Fatal1ty board, trying out new board now
  • 2
    Hoping it was just the board. Trying out different model altogether, but the store didn't have additional CPUs to exchange.

    Here we go!
  • 3
    @ILMostro *fingers crossed*
  • 2
    @avitron We have Lift-off!
    So happy! Thank you all for the words of advice and for keeping my spirits up. Gonna go rip some threads 😁
  • 2
    Forgot the picture
  • 3
    Woop woop
  • 3
    I am glad it works. Ie that a graphics card without a heatsink?
  • 4
  • 2
    @avitron My favorite, Homer FTW!

    @jobylie It has a heatsink, Radeon 550. I'll upgrade later after replenishing funds 😁
  • 1
    @ILMostro what is the planed update?
  • 1
    @RageBone Honestly, haven't even gotten that far. I'm ecstatic to have 32 virtual CPUs (threads; 16 cores) to work with now. Programming, virtualization mainly. Although, being able to play games well is a great bonus. So, maybe the gaming aspect will lead to GPU upgrades, CUDA or GL interests will follow I'm sure. Though, I think upgrading the system with additional NVMe storage will probably come first, especially as this Motherboard allows using those to boot from unlike some others I've read about.
Add Comment