There are few developer who name their functions all wrong, but the functionality is fine. Then there comes those who name their functions right but the functionality is nothing close to what it says. There is this function I debugged. It's name is optimizeQuery. It does not optimize the query at all. Rather dismantles it. Also it made it's way to the production. 😅 Now I have to correct and optimize the optimizeQuery.

  • 1
    So the function optimizeQuery now has to be optimizedQueryOptimizeQuery? What in the name of optimization have you done. The holy lord of optimization is going to punish you for whoever is going to suffer maintaining it.
  • 3
    @MacDev I got rid of it and wrote my own function with appropriate name. 😇
  • 1
    This is exactly why I hate devs that don't care about code quality
  • 0
    I've learnt to never trust function names.
Add Comment