Ranter
Join devRant
Do all the things like
++ or -- rants, post your own rants, comment on others' rants and build your customized dev avatar
Sign Up
Pipeless API
From the creators of devRant, Pipeless lets you power real-time personalized recommendations and activity feeds using a simple API
Learn More
Comments
-
😂😂😂
I laugh, but I've seen the same. The excuse given was: "it's more readable" -
It started by me complaining that
If (value == true)...
Is redundant. And that
If (value!= null && !value.isEmpty() || otherValue == null && !otherValue.is....)
Is not readable and the condition could go to a function.
So the solution for the second was used for both.
D'oh -
Gerschtli518yProbably the implentation of isTrue will change in the future, better be prepared! :D
-
The good old tri-state enum
Boolean{
TRUE , false, file-not-found;
}
http://thedailywtf.com/articles/..._
Related Rants
After I read clean code I talked to a fellow developer about some concepts. Later I reviewed some code of him and he clearly got the concept (not)
Java
...
If (isTrue(someValue))...
public boolean isTrue(boolean value){
if(value == true)
return true;
else
return false;
}
undefined
boolean2boolean converter
clean code