While parsing nodes in a graph.
In terms of readability and variable naming, how wrong (if at all) is to use:
1. broNode (for sibling nodes)
2. papaNode / mamaNode (for parent nodes)
3. babyNode (for child nodes)

I sincerely don't know how to review this PR

  • 10
    If you want readability, why not stick with the normal terminology of parent, child and sibling node? It's literally how they're called by default and if you change that, people will first have to look up what those mamanodes etc are. And I would personally get confused when seeing both mama and papa nodes etc: this implies a difference in function of those nodes.
    Why would you want to move away from the standard terminology? It only makes it harder for other people to process and probably stands in the way of team-focused projects because nobody else probably uses such names for their nodes (except if you decide that this is your coding standard I guess..).

    Plus it sounds kinda childish and unprofessional to me IMHO, but that could be me...
  • 4
    Just use conventional names
    If it's someone else who uses that, tell them to rename all that
  • 6
    Thanks for the input guys. I just saw this in the code i was reviewing, and it made me laugh because its kind of silly and i know the developer who wrote this.

    I was wondering should i comment about it or leave it as chuckles in the repository (since the meaning behind it is clear, at least to me).

    But after your responses i think its best to decline with a comment.
  • 3
    Hahaha, no
  • 3
    @bioDan you definitely should point that out
  • 5
    Please don't merge for orphanNodes please 🥺
  • 2
    @bioDan yeah no, I'd suggest declining it and suggest changing it back to the standard naming convention. Will make everyone happier in the long run!
Add Comment