OOP programming be like....

  • 5
    OOP tutorials should lead with this graphic
  • 3
    This is unrelated to OOP
  • 1
    @linux-colonel this is the essence of OOP as God meant it to be. People think that OOP=Inheritance for some reason; if so, OOP is a Bad Thing.
  • 3
    This isn't OOP. This is just someone who comes up with overly complex (and shit) names
  • 2
    Usually these are the kind of examples I absolutely forbid myself total use.

    Teaching OOP involves having a real examples with at least a modest complex hierarchy - if people get it right, they understand that designing OOP ist basically teaching a computer workflows.

    Interface - Who are u and what can u do?

    Factory - I have some variables laying around, can u provide me with an object that I can actually use?

    Decorator - Feeling fancy, I News additional stuff that modifies my boring being...

    And so on. Most people only der nouns, and try to model these nouns to OOP, but that ist the wrong approach...
  • 1
    @linux-colonel the names are shitty and irrelevant. The fact that the items are referred to by the function they perform is how OOP should be done (interfaces)
  • 0
    Would also work as Java naming conventions.
  • 0
    Feel like the couch should be assetLoadBalancer
  • 1
    multi Butt supporter 😂
  • 0
    I know this pic as the bad example of naming things in the context of domain driven design (DDD). In DDD you'll use the names of the Language.
Add Comment